Video: One Newbie Mistake I Often Encounter

December 3, 2009 , 2 Comments

“I’ve set up my site and submitted it to social bookmarking sites. I’ve written articles with links to it and have done all the on-page SEO stuff, but I’m still not getting a lot of traffic and I’m not making any sales. What am I doing wrong?”

You’ll have encountered this type of question a fair amount of times if you frequent any Internet marketing forums. Since I just saw two prime examples of this question today, I decided to make a video addressing what is most commonly the problem in these cases.

 

About ​Shane Melaugh

I'm the founder of ActiveGrowth and Thrive Themes and over the last years, I've created and marketed a dozen different software, information and SaaS products. Apart from running my business, I spend most of my time reading, learning, developing skills and helping other people develop theirs. On ActiveGrowth, I want to help you become a better entrepreneur and product creator. Read more about my story here.


​Related Articles

  • Ian Davis says:

    Good stuff mate. I’ve got a lot of thinking to do. I’ve found your posts to be refreshingly honest and very helpful.

    Reply

    • Thanks for your comment, Ian. It’s always great to get feedback and I’m very glad to hear that you appreciate my posts. :)

      Reply

  • {"email":"Email address invalid","url":"Website address invalid","required":"Required field missing"}

    ​Develop the Ultimate Entrepreneurial Superpower: Productivity!

    ​Countless "wantrepreneurs" fail to achieve their business goals - not because of a lack of knowledge, but because of a lack of productive, effective implementation. Don't be one of them.

    >